CVSS 4.0
Вероятност да бъде експлоатирана в следващите 30 дни (EPSS)
Атакува се
Време до експлоатация
Атакува се по мрежата, без особени условия, само при определена конфигурация или състояние на системата, без вход и след действие от потребителя.
- Експлоатация: няма данни за експлоатация
- Атаката не може да се автоматизира
Описание
Оригинално описание
Composer is a dependency Manager for the PHP language. From 1.0 until 2.2.30 and 2.10.3, a malicious dependency package from a custom Composer repository or an untrusted composer.lock file could set source.type to perforce and source.url to an rsh: or jsh: P4PORT value. When the Perforce p4 client was installed and Composer installed the package from source through composer install or composer update, including --prefer-source, Composer\Util\Perforce passed the address to p4 without validation, causing p4 to run a local command with the privileges of the user or CI account. Packagist.org does not permit Perforce source metadata. This issue is fixed in versions 2.2.30 and 2.10.3.
Засегнати продукти
- composer composer: >= 1.0, < 2.2.30; >= 2.3.0, < 2.10.3
Вид слабост
История
- 1 септември 2026 Публикувано
Други уязвимости в composer composer
Първоизточници
- https://www.cve.org/CVERecord?id=CVE-2026-84361
- https://nvd.nist.gov/vuln/detail/CVE-2026-84361
- https://github.com/composer/composer/security/advisories/GHSA-rvx4-ffvw-m9q3
- https://github.com/composer/composer/commit/0aac50528e83ed635cf788333635897469440220
- https://github.com/composer/composer/commit/199ad81a9cc6a2a5164ad79a8da26b2e19e521af
- https://github.com/composer/composer/releases/tag/2.10.3
- https://github.com/composer/composer/releases/tag/2.2.30