7.0
CVSS 3.1
Няма данни
Вероятност да бъде експлоатирана в следващите 30 дни (EPSS)
Няма потвърждение
Атакува се
Няма данни
Време до експлоатация
Атакува се локално, при специфични условия, без вход и след действие от потребителя.
- Експлоатация: няма данни за експлоатация
- Атаката не може да се автоматизира
Описание
Оригинално описание
Composer is a dependency Manager for the PHP language. Prior to 2.2.29 and 2.10.2, a maliciously crafted package from an untrusted repository other than Packagist.org or Private Packagist can cause Composer to write attacker-controlled files outside the vendor directory and outside the project during install or update by using an invalid package name that is not correctly validated before dependency-resolution results are written or installed. This issue is fixed in versions 2.2.29 and 2.10.2.
Засегнати продукти
- composer composer: >= 1.0, < 2.2.29; >= 2.3.0, < 2.10.2
Вид слабост
История
- 8 юли 2026 Публикувано
Други уязвимости в composer composer
Първоизточници
- https://www.cve.org/CVERecord?id=CVE-2026-59948
- https://nvd.nist.gov/vuln/detail/CVE-2026-59948
- https://github.com/composer/composer/security/advisories/GHSA-499r-g7pc-vmp9
- https://github.com/composer/composer/commit/502c6c4f699802d9cf464728b3e8a95674f919a0
- https://github.com/composer/composer/commit/c50b1efd13ebd73f6dca19b31424c5a02bf93cc1
- https://github.com/composer/composer/releases/tag/2.10.2
- https://github.com/composer/composer/releases/tag/2.2.29