CVSS 4.0
Вероятност да бъде експлоатирана в следващите 30 дни (EPSS)
Атакува се
Време до експлоатация
Атакува се локално, при специфични условия, само при определена конфигурация или състояние на системата, без вход и след действие от потребителя.
- Експлоатация: има публичен пример за експлоатация
- Атаката не може да се автоматизира
Описание
Оригинално описание
CodeWhale versions >= 0.3.10 and < 0.8.64 (published as deepseek-tui >= 0.3.10 and < 0.8.41 on npm and 0.3.10 through 0.8.41 on crates.io, and as codewhale / codewhale-tui >= 0.8.41 and < 0.8.64) contain a vulnerability in the exec_shell_interact (alias exec_interact) tool, whose approval_requirement returns ApprovalRequirement::Auto. This overrides the default Required approval for code-executing tools, so LLM-controlled stdin is written into an already-approved long-running interactive shell (e.g., a python3 -i REPL, mysql, ssh, or sudo -i session) without any approval prompt. An attacker who can inject instructions via untrusted content the agent ingests (a fetched page, MCP result, or repo file) can cause commands to run at the privilege level of that approved process. Fixed in codewhale / codewhale-tui 0.8.64; the deprecated deepseek-tui crate has no fixed release.
Засегнати продукти
- Hmbown CodeWhale: 0.3.10 до 0.8.41
- Hmbown CodeWhale: 0.3.10 преди 0.8.41; 0.8.41
- Hmbown CodeWhale: 0.8.41 преди 0.8.64; 0.8.64
- Hmbown CodeWhale: 0.8.41 преди 0.8.64; 0.8.64
Вид слабост
История
- 18 август 2026 Публикувано
Други уязвимости в Hmbown CodeWhale
Първоизточници
- https://www.cve.org/CVERecord?id=CVE-2026-75857
- https://nvd.nist.gov/vuln/detail/CVE-2026-75857
- https://github.com/Hmbown/CodeWhale/security/advisories/GHSA-g29h-pfmp-qp9r
- https://github.com/Hmbown/CodeWhale/commit/57f3c89471e27ac4032d9791f6885e5d4408c381
- https://www.vulncheck.com/advisories/codewhale-before-privilege-escalation-via-exec-shell-interact