CVSS 3.1
Вероятност да бъде експлоатирана в следващите 30 дни (EPSS)
Атакува се
Време до експлоатация
Атакува се по мрежата, без особени условия, без вход и след действие от потребителя.
- Експлоатация: има публичен пример за експлоатация
- Атаката не може да се автоматизира
Описание
Оригинално описание
CodeWhale versions >= 0.3.27 and < 0.8.64 (published as deepseek-tui >= 0.3.27 and < 0.8.41 on npm and 0.3.27 through 0.8.41 on crates.io, and as codewhale / codewhale-tui >= 0.8.41 and < 0.8.64) contain an argument injection vulnerability in the git_show tool. The model-supplied rev parameter is passed unvalidated into the git show argv without an --end-of-options sentinel, so a value beginning with --output= is interpreted as a git flag. Because the tool is registered as auto-approved and advertised as read-only, an attacker (via a malicious repository combined with prompt injection) can cause an unprompted arbitrary file write at the privilege of the invoking user, targeting sensitive files such as ~/.ssh/authorized_keys, ~/.bashrc, or ~/.gitconfig. Fixed in codewhale / codewhale-tui 0.8.64 by adding rev validation; the deprecated deepseek-tui crate has no fixed release.
Засегнати продукти
- Hmbown CodeWhale: 0.3.27 до 0.8.41
- Hmbown CodeWhale: 0.3.27 преди 0.8.41; 0.8.41
- Hmbown CodeWhale: 0.8.41 преди 0.8.64; 0.8.64
- Hmbown CodeWhale: 0.8.41 преди 0.8.64; 0.8.64
Вид слабост
История
- 18 август 2026 Публикувано
Други уязвимости в Hmbown CodeWhale
Първоизточници
- https://www.cve.org/CVERecord?id=CVE-2026-75913
- https://nvd.nist.gov/vuln/detail/CVE-2026-75913
- https://github.com/Hmbown/CodeWhale/security/advisories/GHSA-7j5w-7r7x-9v27
- https://github.com/Hmbown/CodeWhale/commit/9a34b5034d29f05d1f28fa61b04719ca6a741020
- https://www.vulncheck.com/advisories/codewhale-before-argument-injection-via-git-show