CVSS 4.0
Вероятност да бъде експлоатирана в следващите 30 дни (EPSS)
Атакува се
Време до експлоатация
Атакува се по мрежата, без особени условия, без вход и без действие от потребителя.
Описание
Оригинално описание
Insufficiently Protected Credentials vulnerability in Apache Juneau. The Apache Juneau RestClient followed HTTP redirects while keeping credential headers from the original request, so a server that redirected the client to a different host or port, or from HTTPS to HTTP, could receive headers such as Authorization, Cookie, Proxy-Authorization and X-API-Key. This issue affects Apache Juneau: through 9.2.0. Users are recommended to upgrade to version 9.2.1, which fixes the issue. The fix applies to HTTP clients created by the RestClient builder; applications that supply their own HttpClient must disable automatic redirects or strip credential headers on cross-origin redirects themselves.
Засегнати продукти
- Apache Software Foundation Apache Juneau: преди 9.2.1
- Apache Software Foundation Apache Juneau: преди 9.2.1
Вид слабост
История
- 5 ноември 2026 Публикувано
Други уязвимости в Apache Software Foundation Apache Juneau
- 10.0CVE-2026-121489
- 10.0CVE-2026-96677
- 10.0CVE-2026-73117
- 10.0CVE-2026-73101
- 10.0CVE-2026-73100