CVSS 3.1
Вероятност да бъде експлоатирана в следващите 30 дни (EPSS)
Атакува се
Време до експлоатация
Атакува се по мрежата, без особени условия, с обикновен потребителски вход и след действие от потребителя.
- Експлоатация: има публичен пример за експлоатация
- Атаката не може да се автоматизира
Описание
Оригинално описание
The Code Embed WordPress plugin prior to version 2.6.1 is vulnerable to stored Cross-Site Scripting (XSS) through the external URL embed feature in post content. The vulnerable code scans rendered content for URL embed tokens, fetches the remote URL, and inserts the remote response body into the page without output sanitization or an `unfiltered_html` capability check. This allows a Contributor attacker to submit a pending post containing an inert-looking URL token that executes attacker-controlled JavaScript when an Administrator or Editor previews or reviews the post. This is distinct from CVE-2026-2512, which affected custom field meta values up to version 2.5.1. This vector affects version 2.6 and uses the documented external URL embed feature in post content. This particular issue is patched in version 2.6.1.
Засегнати продукти
- dartiss code-embed: < 2.6.1
Вид слабост
История
- 7 август 2026 Публикувано
Първоизточници
- https://www.cve.org/CVERecord?id=CVE-2026-48093
- https://nvd.nist.gov/vuln/detail/CVE-2026-48093
- https://github.com/dartiss/code-embed/security/advisories/GHSA-7c9x-px5v-5hcp
- https://github.com/dartiss/code-embed/commit/399752029c62fea82a9bc13fd156713fb4d50ea8
- https://github.com/dartiss/code-embed/releases/tag/2.6.1