Към съдържанието

CVE-2026-44580: vercel next.js, XSS

6.1

CVSS 3.1

Няма данни

Вероятност да бъде експлоатирана в следващите 30 дни (EPSS)

Няма потвърждение

Атакува се

Няма данни

Време до експлоатация

Атакува се по мрежата, без особени условия, без вход и след действие от потребителя.

CVE радар: още уязвимости от този вид

  • Експлоатация: няма данни за експлоатация
  • Атаката не може да се автоматизира

Описание

Оригинално описание

Next.js is a React framework for building full-stack web applications. From 13.0.0 to before 15.5.16 and 16.2.5, applications that use beforeInteractive scripts together with untrusted content can be vulnerable to cross-site scripting. In affected versions, serialized script content was not escaped safely before being embedded into the document, which could allow attacker-controlled input to break out of the intended script context and execute arbitrary JavaScript in a visitor's browser. This vulnerability is fixed in 15.5.16 and 16.2.5.

Засегнати продукти

  • vercel next.js: >= 13.0.0, < 15.5.16; >= 16.0.0, < 16.2.5

Вид слабост

История

  • 13 май 2026 Публикувано

Други уязвимости в vercel next.js

Първоизточници

CVE-2026-44580: vercel next.js, XSS | freedomonline.bg