CVSS 4.0
Вероятност да бъде експлоатирана в следващите 30 дни (EPSS)
Атакува се
Време до експлоатация
Атакува се по мрежата, без особени условия, с обикновен потребителски вход и без действие от потребителя.
- Експлоатация: няма данни за експлоатация
- Атаката може да се автоматизира
Описание
Оригинално описание
Langfuse is an open source large language model engineering platform. From version 3.68.0 to before version 3.167.0, there is a role-based-access control flaw in the LLM connection update flow. An authenticated, low-privileged user of role “member” in a project could request the update of an existing LLM connection to an attacker-controlled baseUrl, causing Langfuse to reuse the stored provider secret and redirect the test request to an attacker-controlled endpoint. This could expose the plaintext provider LLM API key for that connection. The attack is only possible if a user is already part of a project and has “member” scoped access. This issue has been patched in version 3.167.0.
Засегнати продукти
- langfuse langfuse: >= 3.68.0, < 3.167.0
Вид слабост
История
- 8 май 2026 Публикувано
Други уязвимости в langfuse langfuse
Първоизточници
- https://www.cve.org/CVERecord?id=CVE-2026-41487
- https://nvd.nist.gov/vuln/detail/CVE-2026-41487
- https://github.com/langfuse/langfuse/security/advisories/GHSA-2524-j966-gfgh
- https://github.com/langfuse/langfuse/pull/13027
- https://github.com/langfuse/langfuse/pull/13055
- https://github.com/langfuse/langfuse/commit/7527bb0d84bc0a3dc24a4b16d22ed2e46e6dddff
- https://github.com/langfuse/langfuse/commit/e12386f9d4368bbfff24a4ad7fd53641091605ff
- https://github.com/langfuse/langfuse/releases/tag/v3.167.0