CVSS 4.0
Вероятност да бъде експлоатирана в следващите 30 дни (EPSS)
Атакува се
Време до експлоатация
Атакува се по мрежата, без особени условия, с обикновен потребителски вход и без действие от потребителя.
- Експлоатация: няма данни за експлоатация
- Атаката не може да се автоматизира
Описание
Оригинално описание
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.6 and 8.6.19, the validation for protected fields only checks top-level query keys. By wrapping a query constraint on a protected field inside a logical operator, the check is bypassed entirely. This allows any authenticated user to query on protected fields to extract field values. All Parse Server deployments have default protected fields and are vulnerable. This vulnerability is fixed in 9.5.2-alpha.6 and 8.6.19.
Засегнати продукти
- parse-community parse-server: >= 9.0.0 < 9.5.2-alpha.6; < 8.6.19
Вид слабост
История
- 10 март 2026 Публикувано
Други уязвимости в parse-community parse-server
Първоизточници
- https://www.cve.org/CVERecord?id=CVE-2026-30962
- https://nvd.nist.gov/vuln/detail/CVE-2026-30962
- https://github.com/parse-community/parse-server/security/advisories/GHSA-72hp-qff8-4pvv
- https://github.com/parse-community/parse-server/releases/tag/8.6.19
- https://github.com/parse-community/parse-server/releases/tag/9.5.2-alpha.6