Към съдържанието

CVE-2026-2005: PostgreSQL, грешка в паметта

8.8

CVSS 3.1

Няма данни

Вероятност да бъде експлоатирана в следващите 30 дни (EPSS)

Няма потвърждение

Атакува се

Няма данни

Време до експлоатация

Атакува се по мрежата, без особени условия, с обикновен потребителски вход и без действие от потребителя.

CVE радар: още уязвимости от този вид

  • Експлоатация: няма данни за експлоатация
  • Атаката не може да се автоматизира

Описание

Оригинално описание

Heap buffer overflow in PostgreSQL pgcrypto allows a ciphertext provider to execute arbitrary code as the operating system user running the database. Versions before PostgreSQL 18.2, 17.8, 16.12, 15.16, and 14.21 are affected.

Засегнати продукти

  • n/a PostgreSQL: 18 преди 18.2; 17 преди 17.8; 16 преди 16.12; 15 преди 15.16; преди 14.21
  • Red Hat Red Hat Enterprise Linux 10: 0:16.13-1.el10_1 преди *; 0:16.13-1.el10_2 преди *
  • Red Hat Red Hat Enterprise Linux 10.0 Extended Update Support: 0:16.13-1.el10_0 преди *
  • Red Hat Red Hat Enterprise Linux 8: 8100020260227180702.489197e6 преди *
  • Red Hat Red Hat Enterprise Linux 8.2 Advanced Update Support: 8020020260309120440.4cda2c84 преди *
  • Red Hat Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Support: 8040020260305144728.522a0ee4 преди *
  • Red Hat Red Hat Enterprise Linux 8.4 Extended Update Support Long-Life Add-On: 8040020260305144728.522a0ee4 преди *
  • Red Hat Red Hat Enterprise Linux 8.6 Advanced Mission Critical Update Support: 8060020260306113941.ad008a3a преди *
  • Red Hat Red Hat Enterprise Linux 8.6 Telecommunications Update Service: 8060020260306113941.ad008a3a преди *
  • Red Hat Red Hat Enterprise Linux 8.6 Update Services for SAP Solutions: 8060020260306113941.ad008a3a преди *
  • Red Hat Red Hat Enterprise Linux 8.8 Telecommunications Update Service: 8080020260302123717.63b34585 преди *
  • Red Hat Red Hat Enterprise Linux 8.8 Update Services for SAP Solutions: 8080020260302123717.63b34585 преди *
  • Red Hat Red Hat Enterprise Linux 9: 0:13.23-2.el9_7 преди *
  • Red Hat Red Hat Enterprise Linux 9.0 Update Services for SAP Solutions: 0:13.23-1.el9_0.1 преди *
  • Red Hat Red Hat Enterprise Linux 9.2 Update Services for SAP Solutions: 9020020260309133405.rhel9 преди *
  • Red Hat Red Hat Enterprise Linux 9.4 Extended Update Support: 0:13.23-1.el9_4.1 преди *
  • Red Hat Red Hat Enterprise Linux 9.6 Extended Update Support: 0:13.23-1.el9_6.1 преди *
  • Red Hat Red Hat Hardened Images: 18.3-1.2.hum1 преди *
  • Red Hat Red Hat Update Infrastructure 5: 1773670137 преди *
  • Red Hat Red Hat Enterprise Linux 6
  • Red Hat Red Hat Enterprise Linux 7

Вид слабост

История

  • 12 февруари 2026 Публикувано

Други уязвимости в n/a PostgreSQL

Първоизточници

CVE-2026-2005: PostgreSQL, грешка в паметта | freedomonline.bg