9.0
CVSS 3.1
Няма данни
Вероятност да бъде експлоатирана в следващите 30 дни (EPSS)
Няма потвърждение
Атакува се
Няма данни
Време до експлоатация
Атакува се по мрежата, без особени условия, с обикновен потребителски вход и след действие от потребителя.
- Експлоатация: няма данни за експлоатация
- Атаката не може да се автоматизира
Описание
Оригинално описание
Improper control of code generation in Amazon @aws-amplify/codegen-ui-react before 2.20.6 might allow a remote authenticated user to execute arbitrary code in end-user browsers, developer machines, CI/CD environments, and server-side rendering contexts via crafted Studio component or theme schema values due to insufficient coverage and effectiveness of the input validation introduced for CVE-2025-4318. To remediate this issue, users should upgrade to version 2.20.6
Засегнати продукти
- AWS Amplify Codegen UI: преди 2.20.6
Вид слабост
История
- 30 юли 2026 Публикувано
Първоизточници
- https://www.cve.org/CVERecord?id=CVE-2026-18245
- https://nvd.nist.gov/vuln/detail/CVE-2026-18245
- https://github.com/aws-amplify/amplify-codegen-ui/releases/tag/v2.20.6
- https://aws.amazon.com/security/security-bulletins/2026-066-aws/
- https://github.com/aws-amplify/amplify-codegen-ui/security/advisories/GHSA-74xx-rjgf-m69j