CVSS 4.0
Вероятност да бъде експлоатирана в следващите 30 дни (EPSS)
Атакува се
Време до експлоатация
Атакува се по мрежата, без особени условия, с обикновен потребителски вход и без действие от потребителя.
- Експлоатация: няма данни за експлоатация
- Атаката не може да се автоматизира
Описание
Оригинално описание
A remote user who can read encrypted objects in the S3 bucket can force a padding downgrade by altering the padding scheme recorded in an object's metadata to legacy PKCS#1 v1.5. Since this padding scheme is susceptible to the well-known Bleichenbacher attack, the user can use a PKCS#1 v1.5 padding oracle to recover the RSA-wrapped envelope key and decrypt the object. To remediate this issue, we recommend that users upgrade to version 3.2.2 or 4.0.3. The 1.x and 2.x lines will not be patched, users of those lines need to migrate to 3.2.2 or 4.0.3.
Засегнати продукти
- Amazon Amazon.Extensions.S3.Encryption: 2.1.0 до 2.*; 3.0.0 до 3.2.1; 4.0.0 до 4.0.2
Вид слабост
История
- 14 октомври 2026 Публикувано
Първоизточници
- https://www.cve.org/CVERecord?id=CVE-2026-110310
- https://nvd.nist.gov/vuln/detail/CVE-2026-110310
- https://www.nuget.org/packages/Amazon.Extensions.S3.Encryption/3.2.2
- https://www.nuget.org/packages/Amazon.Extensions.S3.Encryption/4.0.3
- https://aws.amazon.com/security/security-bulletins/2026-135-aws/
- https://github.com/aws/amazon-s3-encryption-client-dotnet/security/advisories/GHSA-322w-f6rw-r4fj