CVSS 4.0
Вероятност да бъде експлоатирана в следващите 30 дни (EPSS)
Атакува се
Време до експлоатация
Атакува се по мрежата, без особени условия, само при определена конфигурация или състояние на системата, с обикновен потребителски вход и без действие от потребителя.
- Експлоатация: няма данни за експлоатация
- Атаката не може да се автоматизира
Описание
Оригинално описание
Craft is a platform for creating digital experiences. Versions 5.0.0-RC1 through 5.8.20 and 4.0.0-RC1 through 4.16.16 are vulnerable to potential authenticated Remote Code Execution via Twig SSTI. For this to work, users must have administrator access to the Craft Control Panel, and allowAdminChanges must be enabled, which is against Craft CMS' recommendations for any non-dev environment. Alternatively, a non-administrator account with allowAdminChanges disabled can be used, provided access to the System Messages utility is available. It is possible to craft a malicious payload using the Twig `map` filter in text fields that accept Twig input under Settings in the Craft control panel or using the System Messages utility, which could lead to a RCE. Users should update to the patched versions (5.8.21 and 4.16.17) to mitigate the issue.
Засегнати продукти
- craftcms cms: >= 5.0.0-RC1, < 5.8.21; >= 4.0.0-RC1, < 4.16.17
Вид слабост
История
- 5 януари 2026 Публикувано
Други уязвимости в craftcms cms
Първоизточници
- https://www.cve.org/CVERecord?id=CVE-2025-68454
- https://nvd.nist.gov/vuln/detail/CVE-2025-68454
- https://github.com/craftcms/cms/security/advisories/GHSA-742x-x762-7383
- https://github.com/craftcms/cms/commit/d82680f4a05f9576883bb83c3f6243d33ca73ebe
- https://github.com/craftcms/cms/blob/5.x/CHANGELOG.md#5821---2025-12-04