CVSS 3.1
Вероятност да бъде експлоатирана в следващите 30 дни (EPSS)
Атакува се
Време до експлоатация
Атакува се локално, без особени условия, без вход и след действие от потребителя.
- Експлоатация: няма данни за експлоатация
- Атаката не може да се автоматизира
Описание
Оригинално описание
Git is a fast, scalable, distributed revision control system with an unusually rich command set that provides both high-level operations and full access to internals. The wincred credential helper uses a static buffer (target) as a unique key for storing and comparing against internal storage. This credential helper does not properly bounds check the available space remaining in the buffer before appending to it with wcsncat(), leading to potential buffer overflows. This vulnerability is fixed in v2.43.7, v2.44.4, v2.45.4, v2.46.4, v2.47.3, v2.48.2, v2.49.1, and v2.50.1.
Засегнати продукти
- git git: < 2.43.7; >= 2.44.0-rc0, < 2.44.4; >= 2.45.0-rc0, < 2.45.4; >= 2.46.0-rc0, < 2.46.4; >= 2.47.0-rc0, < 2.47.3; >= 2.48.0-rc0, < 2.48.2; >= 2.49.0-rc0, < 2.49.1; >= 2.50.0-rc0, < 2.50.1
Вид слабост
История
- 8 юли 2025 Публикувано