Към съдържанието

CVE-2025-29927: vercel next.js, заобикаляне на вход и права

9.1

CVSS 3.1

Няма данни

Вероятност да бъде експлоатирана в следващите 30 дни (EPSS)

Няма потвърждение

Атакува се

Няма данни

Време до експлоатация

Атакува се по мрежата, без особени условия, без вход и без действие от потребителя.

CVE радар: още уязвимости от този вид

  • Експлоатация: няма данни за експлоатация
  • Атаката може да се автоматизира

Описание

Оригинално описание

Next.js is a React framework for building full-stack web applications. Starting in version 1.11.4 and prior to versions 12.3.5, 13.5.9, 14.2.25, and 15.2.3, it is possible to bypass authorization checks within a Next.js application, if the authorization check occurs in middleware. If patching to a safe version is infeasible, it is recommend that you prevent external user requests which contain the x-middleware-subrequest header from reaching your Next.js application. This vulnerability is fixed in 12.3.5, 13.5.9, 14.2.25, and 15.2.3.

Засегнати продукти

  • vercel next.js: >= 11.1.4, < 12.3.5; >= 14.0.0, < 14.2.25; >= 15.0.0, < 15.2.3; >= 13.0.0, < 13.5.9

Вид слабост

История

  • 21 март 2025 Публикувано

Други уязвимости в vercel next.js

Първоизточници

CVE-2025-29927: vercel next.js, заобикаляне на вход и права | freedomonline.bg