CVSS 3.1
Вероятност да бъде експлоатирана в следващите 30 дни (EPSS)
Атакува се
Време до експлоатация
Атакува се по мрежата, без особени условия, с обикновен потребителски вход и без действие от потребителя.
- Експлоатация: няма данни за експлоатация
- Атаката не може да се автоматизира
Описание
Оригинално описание
The Email Encoder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'eeb_mailto' shortcode in versions up to, and including, 2.1.8 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. A partial patch was issued in version 2.1.8. The vulnerability was fully patched in 2.1.9.
Засегнати продукти
- onlineoptimisation Email Encoder – Protect Email Addresses and Phone Numbers: до 2.1.8
Вид слабост
История
- 30 август 2023 Публикувано
Други уязвимости в onlineoptimisation Email Encoder – Protect Email Addresses and Phone Numbers
Първоизточници
- https://www.cve.org/CVERecord?id=CVE-2023-4599
- https://nvd.nist.gov/vuln/detail/CVE-2023-4599
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e90f04e4-eb4c-4822-89c6-79f553987c37?source=cve
- https://plugins.trac.wordpress.org/browser/email-encoder-bundle/tags/2.1.7/core/includes/classes/class-email-encoder-bundle-run.php#L529
- https://plugins.trac.wordpress.org/changeset/2958823/email-encoder-bundle#file60
- https://plugins.trac.wordpress.org/changeset/2994384/email-encoder-bundle/trunk?contextall=1&old=2958823&old_path=%2Femail-encoder-bundle%2Ftrunk#file0