CVSS 3.1
Вероятност да бъде експлоатирана в следващите 30 дни (EPSS)
Атакува се
Време до експлоатация
Атакува се по мрежата, при специфични условия, без вход и без действие от потребителя.
Описание
Оригинално описание
Fluentd collects events from various data sources and writes them to files to help unify logging infrastructure. The parser_apache2 plugin in Fluentd v0.14.14 to v1.14.1 suffers from a regular expression denial of service (ReDoS) vulnerability. A broken apache log with a certain pattern of string can spend too much time in a regular expression, resulting in the potential for a DoS attack. This issue is patched in version 1.14.2 There are two workarounds available. Either don't use parser_apache2 for parsing logs (which cannot guarantee generated by Apache), or put patched version of parser_apache2.rb into /etc/fluent/plugin directory (or any other directories specified by the environment variable `FLUENT_PLUGIN` or `--plugin` option of fluentd).
Засегнати продукти
- fluent fluentd: >= 0.14.14, < 1.14.2
Вид слабост
История
- 29 октомври 2021 Публикувано
Други уязвимости в fluent fluentd
Първоизточници
- https://www.cve.org/CVERecord?id=CVE-2021-41186
- https://nvd.nist.gov/vuln/detail/CVE-2021-41186
- https://github.com/fluent/fluentd/security/advisories/GHSA-hwhf-64mh-r662
- https://github.com/fluent/fluentd/blob/master/CHANGELOG.md#v1142
- https://github.com/github/securitylab-vulnerabilities/blob/52dc4a2a828c6dc24231967c2937ad92038184a9/vendor_reports/GHSL-2021-102-fluent-fluentd.md